📺 "One project. One language. Three apps." Learn more in our upcoming code sharing webinar!

NativeScript Core

System Requirements

The recommended ways to create NativeScript Applications is either through the Command-Line Interface (CLI) or through the NativeScript Sidekick.

Supported iOS Versions

The iOS Runtime supports officially iOS 9+. The metadata however is generated with the latest SDK. The metadata contains information about API availability so NativeScript allows you to both use the latest APIs, and if necessary, detect and degrade gracefully on lower iOS versions.

Supported JavaScript Features

JavaScript code executing in the iOS Runtime must comply with the supported features of the JavaScriptCore engine. You can view them in detail here.

Supported Application Binary Interfaces (ABI)

Currently supported are the following CPU instruction sets:

  • armv7
  • arm64